Apache Struts 2.x < 2.3.15.1 Multiple Vulnerabilities (S2-016) (S2-017)

critical Nessus Plugin ID 117362

Synopsis

遠端主機上執行的 Web 應用程式使用受多個弱點影響的 Java 架構。

描述

遠端主機上執行的 Apache Struts 版本是比 2.3.15.1 舊的 2.x 版。因此會受到多個弱點影響,包括遠端命令執行弱點和開放重新導向弱點。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Struts 2.3.15.1 版或更新版本

另請參閱

https://cwiki.apache.org/confluence/display/WW/S2-016

https://cwiki.apache.org/confluence/display/WW/S2-017

Plugin 詳細資訊

嚴重性: Critical

ID: 117362

檔案名稱: struts_2_3_15_1.nasl

版本: 1.14

類型: combined

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2018/9/10

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: High

分數: 8.1

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 8.1

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2013-2251

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 9.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:struts

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2013/7/9

弱點發布日期: 2013/7/9

CISA 已知利用日期: 2022/4/15

惡意利用途徑

CANVAS (CANVAS)

Core Impact

Metasploit (Apache Struts 2 DefaultActionMapper Prefixes OGNL Code Execution)

Elliot (Apache-Struts DefaultActionMapper < 2.3.15.1 RCE Linux)

參考資訊

CVE: CVE-2013-2248, CVE-2013-2251

BID: 61189, 61196