Debian DSA-4264-1:python-django - 安全性更新

medium Nessus Plugin ID 111537

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

Andreas Hug 在 Django (一種 Python 網頁開發架構) 中發現一個開放重新導向,當使用 django.middleware.common.CommonMiddleware 並啟用 APPEND_SLASH 設定時,可遭到惡意利用。

解決方案

升級 python-django 套件。針對穩定的發行版本 (stretch),此問題已在 1:1.10.7-2+deb9u2 版本中修正。

另請參閱

http://www.nessus.org/u?22eb32f6

https://packages.debian.org/source/stretch/python-django

https://www.debian.org/security/2018/dsa-4264

Plugin 詳細資訊

嚴重性: Medium

ID: 111537

檔案名稱: debian_DSA-4264.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2018/8/6

已更新: 2018/11/13

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Low

分數: 3

CVSS v2

風險因素: Medium

基本分數: 5.8

媒介: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS v3

風險因素: Medium

基本分數: 6.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

弱點資訊

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-django:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

修補程式發佈日期: 2018/8/5

參考資訊

CVE: CVE-2018-14574

DSA: 4264