Debian DSA-4254-1:slurm-llnl - 安全性更新

critical Nessus Plugin ID 111316

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在 Simple Linux Utility for Resource Management (SLURM) (一種叢集資源管理和工作排程系統) 中發現數個弱點。Common Vulnerabilities and Exposures 專案發現下列問題:- CVE-2018-7033 未完整清理使用者提供的文字字串可導致對 slurmdbd 進行 SQL 插入攻擊。- CVE-2018-10995 未安全地處理 user_name 和 gid 欄位可導致不當處理驗證。

解決方案

升級 slurm-llnl 套件。針對穩定的發行版本 (stretch),這些問題已在 16.05.9-1+deb9u2 版本中修正。

另請參閱

https://packages.debian.org/source/stretch/slurm-llnl

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893044

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900548

https://security-tracker.debian.org/tracker/CVE-2018-7033

https://security-tracker.debian.org/tracker/CVE-2018-10995

https://security-tracker.debian.org/tracker/source-package/slurm-llnl

https://www.debian.org/security/2018/dsa-4254

Plugin 詳細資訊

嚴重性: Critical

ID: 111316

檔案名稱: debian_DSA-4254.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2018/7/25

已更新: 2018/11/13

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: Critical

基本分數: 9.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

弱點資訊

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:slurm-llnl:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

修補程式發佈日期: 2018/7/24

參考資訊

CVE: CVE-2018-7033, CVE-2018-10995

DSA: 4254