Oracle Java SE Multiple Vulnerabilities (July 2018 CPU) (Unix)

critical Nessus Plugin ID 111162
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Unix 主機包含的程式設計平台受到多種弱點的影響。

描述

遠端主機上安裝的 Oracle (之前稱為 Sun) Java SE 或 Java for Business 版本比 10 Update 2、8 Update 181、7 Update 191,或 6 Update 201 舊。因此,會受到和下列元件有關的多個弱點所影響:- Concurrency。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE (CVE-2018-2952) - Deployment。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE (CVE-2018-2964) - JSSE。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE (CVE-2018-2973) - Java DB。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE。(CVE-2018-2938) - JavaFX。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE。(CVE-2018-2941) - Libraries。可輕易利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE。(CVE-2018-2940) - Security。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE (CVE-2018-2972) - Windows DLL。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定來危害 Java SE (CVE-2018-2942) 請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Oracle JDK / JRE 10 Update 2、8 Update 181 / 7 Update 191 / 6 Update 201 或更新版本。視需要移除任何受影響的版本。請注意,需要 Oracle 的延伸維護合約才能取得 JDK / JRE 6 Update 95 或更新版本。

另請參閱

http://www.nessus.org/u?dbb3b1db

http://www.nessus.org/u?8a11ccea

http://www.nessus.org/u?6c975c0b

http://www.nessus.org/u?2fbcacca

http://www.nessus.org/u?726f7054

Plugin 詳細資訊

嚴重性: Critical

ID: 111162

檔案名稱: oracle_java_cpu_jul_2018_unix.nasl

版本: 1.6

類型: local

代理程式: unix

系列: Misc.

已發布: 2018/7/20

已更新: 2019/11/5

相依性: sun_java_jre_installed_unix.nasl

風險資訊

CVSS 評分資料來源: CVE-2018-2938

VPR

風險因素: Medium

分數: 6.5

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9

時間分數: 7.8

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:oracle:jre, cpe:/a:oracle:jdk

必要的 KB 項目: Host/Java/JRE/Installed

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2018/7/17

弱點發布日期: 2018/7/17

參考資訊

CVE: CVE-2018-2938, CVE-2018-2940, CVE-2018-2941, CVE-2018-2952, CVE-2018-2964, CVE-2018-2972, CVE-2018-2973

BID: 104765, 104768, 104773, 104774, 104775, 104780, 104782