Ubuntu 14.04 LTS / 16.04 LTS / 17.10 / 18.04 LTS:檔案弱點 (USN-3686-1)

high Nessus Plugin ID 110552
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性相關修補程式。

描述

Alexander Cherepanov 發現 file 未正確處理大量附註。攻擊者可利用此問題引發拒絕服務。這個問題只會影響 Ubuntu 14.04 LTS。(CVE-2014-9620)

Alexander Cherepanov 發現 file 未正確處理某些長字串。攻擊者可利用此問題引發拒絕服務。這個問題只會影響 Ubuntu 14.04 LTS。(CVE-2014-9621)

Alexander Cherepanov 發現 file 未正確處理某些格式錯誤的 ELF 檔案。攻擊者可利用此問題,造成拒絕服務或可能執行任意程式碼。這個問題只會影響 Ubuntu 14.04 LTS。(CVE-2014-9653)

據發現,file 未正確處理某些 magic 檔案。
攻擊者可利用此問題搭配特製的 magic 檔案造成拒絕服務,或可能執行任意程式碼。這個問題只會影響 Ubuntu 14.04 LTS。(CVE-2015-8865)

據發現,檔案未正確處理某些格式錯誤的 ELF 檔案。攻擊者可利用此問題引發拒絕服務。
(CVE-2018-10360)。

請注意,Tenable Network Security 已直接從 Ubuntu 安全性公告擷取前述描述區塊。Tenable 已嘗試在不造成其他問題的前提下,盡可能完成自動清理並將其格式化。

解決方案

更新受影響的 file 和/或 libmagic1 套件。

另請參閱

https://usn.ubuntu.com/3686-1/

Plugin 詳細資訊

嚴重性: High

ID: 110552

檔案名稱: ubuntu_USN-3686-1.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2018/6/15

已更新: 2020/9/17

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: High

基本分數: 7.3

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

弱點資訊

CPE: p-cpe:/a:canonical:ubuntu_linux:file, p-cpe:/a:canonical:ubuntu_linux:libmagic1, cpe:/o:canonical:ubuntu_linux:14.04, cpe:/o:canonical:ubuntu_linux:16.04, cpe:/o:canonical:ubuntu_linux:17.10, cpe:/o:canonical:ubuntu_linux:18.04:-:lts

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

修補程式發佈日期: 2018/6/14

弱點發布日期: 2015/1/21

參考資訊

CVE: CVE-2014-9620, CVE-2014-9621, CVE-2014-9653, CVE-2015-8865, CVE-2018-10360

USN: 3686-1