RHEL 7:java-1.8.0-oracle (RHSA-2018:1204)

high Nessus Plugin ID 109305
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Red Hat 主機缺少一個或多個安全性更新。

描述

現已提供適用於 Red Hat Enterprise Linux 7 之 Oracle Java 的 java-1.8.0-oracle 更新。Red Hat 產品安全性團隊已將此更新評等為具有重大安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。Oracle Java SE 8 版包含 Oracle Java Runtime Environment 和 Oracle Java Software Development Kit。此更新會將 Oracle Java SE 8 升級至版本 8 Update 171。安全性修正:* OpenJDK:錯誤處理參照複製可導致沙箱繞過 (Hotspot,8192025) (CVE-2018-2814) * OpenJDK:從 JCEKS 金鑰存放庫資料的無限制還原序列化 (Security,8189997) (CVE-2018-2794) * Oracle JDK:在 8u171 和 10.0.1 中修正未指定的弱點 (Install) (CVE-2018-2811) * OpenJDK:多個類別的還原序列化中一致性檢查不足 (Security,8189977) (CVE-2018-2795) * OpenJDK:在 PriorityBlockingQueue 中進行還原序列化期間發生未繫結的記憶體配置 (Concurrency,8189981) (CVE-2018-2796) * OpenJDK:在 TabularDataSupport 中進行還原序列化期間發生未繫結的記憶體配置 (JMX,8189985) (CVE-2018-2797) * OpenJDK:在 Container 中進行還原序列化期間發生未繫結的記憶體配置 (AWT,8189989) (CVE-2018-2798) * OpenJDK:在 NamedNodeMapImpl 中進行還原序列化期間發生未繫結的記憶體配置 (JAXP,8189993) (CVE-2018-2799) * OpenJDK:預設啟用 RMI HTTP 傳輸 (RMI,8193833) (CVE-2018-2800) * OpenJDK:在 StubIORImpl 中進行還原序列化期間發生未繫結的記憶體配置 (Serialization,8192757) (CVE-2018-2815) * OpenJDK:錯誤合併 JAR 資訊清單中的區段 (Security,8189969) (CVE-2018-2790) 如需安全性問題的詳細資料,包括影響、CVSS 分數及其他相關資訊,請參閱〈參照〉一節列出的 CVE 頁面。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/errata/RHSA-2018:1204

https://access.redhat.com/security/cve/cve-2018-2790

https://access.redhat.com/security/cve/cve-2018-2794

https://access.redhat.com/security/cve/cve-2018-2795

https://access.redhat.com/security/cve/cve-2018-2796

https://access.redhat.com/security/cve/cve-2018-2797

https://access.redhat.com/security/cve/cve-2018-2798

https://access.redhat.com/security/cve/cve-2018-2799

https://access.redhat.com/security/cve/cve-2018-2800

https://access.redhat.com/security/cve/cve-2018-2811

https://access.redhat.com/security/cve/cve-2018-2814

https://access.redhat.com/security/cve/cve-2018-2815

Plugin 詳細資訊

嚴重性: High

ID: 109305

檔案名稱: redhat-RHSA-2018-1204.nasl

版本: 1.10

類型: local

代理程式: unix

已發布: 2018/4/24

已更新: 2021/3/11

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6.5

CVSS v2

風險因素: Medium

基本分數: 5.1

媒介: AV:N/AC:H/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: High

基本分數: 8.3

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

弱點資訊

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle-devel, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle-javafx, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-oracle-src, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.5

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

修補程式發佈日期: 2018/4/23

弱點發布日期: 2018/4/18

參考資訊

CVE: CVE-2018-2790, CVE-2018-2794, CVE-2018-2795, CVE-2018-2796, CVE-2018-2797, CVE-2018-2798, CVE-2018-2799, CVE-2018-2800, CVE-2018-2811, CVE-2018-2814, CVE-2018-2815

RHSA: 2018:1204