PHP 7.0.x < 7.0.28 堆疊緩衝區溢位

critical Nessus Plugin ID 107217

Synopsis

遠端網頁伺服器上執行的 PHP 版本受到一個堆疊緩衝區溢位弱點影響。

描述

根據其標題,遠端網頁伺服器上安裝的 PHP 版本為 7.0.28 之前的 7.0.x 版。因此,會受到一個堆疊緩衝區溢位弱點影響。

解決方案

升級為 PHP 7.0.28 或更新版本。

另請參閱

http://php.net/ChangeLog-7.php#7.0.28

http://www.nessus.org/u?77aa0aa0

Plugin 詳細資訊

嚴重性: Critical

ID: 107217

檔案名稱: php_7_0_28.nasl

版本: 1.6

類型: remote

系列: CGI abuses

已發布: 2018/3/8

已更新: 2022/4/11

風險資訊

CVSS 評分資料來源: CVE-2018-7584

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2018/3/1

弱點發布日期: 2018/3/1

參考資訊

CVE: CVE-2018-7584