JQuery 1.x < 1.12.0 / 2.x < 2.2.0 XSS

medium Nessus Plugin ID 106657

Synopsis

遠端網頁伺服器受到跨網站指令碼弱點的影響。

描述

遠端網頁伺服器上主控的 JQuery 程式庫版本是比 1.12.0 舊的 1.x 版或比 2.2.0 舊的 2.x 版。因此,使用 location.host 來選取元素時,會受到一個跨網站指令碼弱點的影響。

解決方案

升級至 JQuery 1.12.0 或更新版本。

另請參閱

https://blog.jquery.com/2016/01/08/jquery-2-2-and-1-12-released/

Plugin 詳細資訊

嚴重性: Medium

ID: 106657

檔案名稱: jquery_2_2_0.nasl

版本: 1.6

類型: remote

已發布: 2018/2/7

已更新: 2020/11/24

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分論據: Score based on analysis of the vendor advisory.

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.7

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: manual

CVSS v3

風險因素: Medium

基本分數: 4.7

時間分數: 4.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:jquery:jquery

必要的 KB 項目: Settings/ParanoidReport, installed_sw/jquery

可輕鬆利用: No exploit is required

修補程式發佈日期: 2015/9/10

弱點發布日期: 2015/6/15