JQuery 1.6.x < 1.6.3 XSS

medium Nessus Plugin ID 106656

Synopsis

遠端網頁伺服器受到跨網站指令碼弱點的影響。

描述

根據其指令碼中自我報告的版本,遠端網頁伺服器上主控的 JQuery 版本為 1.6.3 之前的 1.6.x 版。因此,使用 location.hash 來選取元素時,會受到一個跨網站指令碼弱點的影響。

解決方案

升級至 JQuery 1.6.3 或更新版本。

另請參閱

https://blog.jquery.com/2011/09/01/jquery-1-6-3-released/

Plugin 詳細資訊

嚴重性: Medium

ID: 106656

檔案名稱: jquery_1_6_3.nasl

版本: 1.4

類型: remote

已發布: 2018/2/7

已更新: 2019/5/3

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Low

分數: 1.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2011-4969

CVSS v3

風險因素: Medium

基本分數: 4.7

時間分數: 4.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

必要的 KB 項目: Settings/ParanoidReport, installed_sw/jquery

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2011/9/1

弱點發布日期: 2011/9/1

參考資訊

CVE: CVE-2011-4969

BID: 58458