Debian DSA-4080-1:php7.0 - 安全性更新

critical Nessus Plugin ID 105663

語系:

新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

在廣為使用的開放來源一般用途指令碼語言 PHP 中發現數個弱點:- CVE-2017-11144 未正確檢查 OpenSSL 密封函式的傳回值,造成在 openssl 延伸模組中引發拒絕服務 - CVE-2017-11145 wddx_deserialize() 中存在超出邊界讀取 - CVE-2017-11628 PHP INI 剖析 API 中存在緩衝區溢位 - CVE-2017-12932 / CVE-2017-12934 還原序列化期間發生釋放後使用錯誤 - CVE-2017-12933 finish_nested_data() 中存在緩衝區過度讀取 - CVE-2017-16642 timelib_meridian() 中存在超出邊界讀取

解決方案

升級 php7.0 套件。針對穩定的發行版本 (stretch),這些問題已在 7.0.27-0+deb9u1 版本中修正。

另請參閱

https://security-tracker.debian.org/tracker/source-package/php7.0

https://packages.debian.org/source/stretch/php7.0

https://security-tracker.debian.org/tracker/CVE-2017-11144

https://security-tracker.debian.org/tracker/CVE-2017-11145

https://security-tracker.debian.org/tracker/CVE-2017-11628

https://security-tracker.debian.org/tracker/CVE-2017-12933

https://security-tracker.debian.org/tracker/CVE-2017-16642

https://security-tracker.debian.org/tracker/CVE-2017-12932

https://security-tracker.debian.org/tracker/CVE-2017-12934

https://www.debian.org/security/2018/dsa-4080

Plugin 詳細資訊

嚴重性: Critical

ID: 105663

檔案名稱: debian_DSA-4080.nasl

版本: 3.5

類型: local

代理程式: unix

已發布: 2018/1/9

已更新: 2019/4/5

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:P/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.0:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2018/1/8

參考資訊

CVE: CVE-2017-16642, CVE-2017-11144, CVE-2017-11145, CVE-2017-11628, CVE-2017-12933, CVE-2017-12932, CVE-2017-12934

DSA: 4080