Debian DSA-4079-1:poppler - 安全性更新

high Nessus Plugin ID 105623

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

在 poppler PDF 轉譯程式庫中發現多個弱點,如果處理格式錯誤的 PDF 檔案,可能導致拒絕服務或執行任意程式碼。

解決方案

升級 poppler 套件。

針對舊的穩定發行版本 (jessie),這些問題已在 0.26.5-2+deb8u2 版本中修正。

針對穩定的發行版本 (stretch),這些問題已在 0.48.0-2+deb9u1 版本中修正。

另請參閱

https://security-tracker.debian.org/tracker/source-package/poppler

https://packages.debian.org/source/jessie/poppler

https://packages.debian.org/source/stretch/poppler

https://www.debian.org/security/2018/dsa-4079

Plugin 詳細資訊

嚴重性: High

ID: 105623

檔案名稱: debian_DSA-4079.nasl

版本: 3.8

類型: local

代理程式: unix

已發布: 2018/1/8

已更新: 2019/3/15

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: Medium

基本分數: 6.8

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

風險因素: High

基本分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:poppler, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

修補程式發佈日期: 2018/1/7

弱點發布日期: 2017/6/2

參考資訊

CVE: CVE-2017-14517, CVE-2017-14518, CVE-2017-14519, CVE-2017-14520, CVE-2017-14975, CVE-2017-14976, CVE-2017-14977, CVE-2017-15565, CVE-2017-9406, CVE-2017-9408, CVE-2017-9775, CVE-2017-9776, CVE-2017-9865

DSA: 4079