Apache 2.4.x < 2.4.28 HTTP 弱點 (OptionsBleed)

high Nessus Plugin ID 103838

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 版本是比 2.4.28 舊的 2.4.x 版。因此,該應用程式受到 .htaccess 檔案中與 < Limit {method}> 指示詞相關的 HTTP 弱點影響。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.28 或更新版本。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.28

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: High

ID: 103838

檔案名稱: apache_2_4_28.nasl

版本: 1.10

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2017/10/13

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.9

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2017-9798

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要的 KB 項目: installed_sw/Apache

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2017/10/5

弱點發布日期: 2017/9/18

參考資訊

CVE: CVE-2017-9798

BID: 100872