Oracle Linux 6 : httpd (ELSA-2017-2478)

critical Nessus Plugin ID 102514
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Oracle Linux 主機缺少一個或多個安全性更新。

描述

來自 Red Hat 安全公告 2017:2478: 現已提供適用於 Red Hat Enterprise Linux 6 的 httpd 更新。 Red Hat 產品安全性團隊已將此更新評等為具有重要安全性影響。可從〈參照〉一節的 CVE 連結中取得每個弱點之常見弱點評分系統 (CVSS) 的基本分數,其中包含有關嚴重性評等的詳細資訊。 httpd 套件提供 Apache HTTP Server,這是一款強大、有效且可延伸的 Web 伺服器。 安全性修正: * 據發現,httpd 的 mod_auth_digest 模組在處理某些與摘要認證相關的特定標頭時,使用記憶體前未正確初始化記憶體。遠端攻擊者可能會利用此缺陷洩漏潛在的敏感資訊,或透過傳送特製的要求給伺服器,造成 httpd 子處理程序損毀。(CVE-2017-9788) * 據發現,在身份驗證階段外使用 httpd 的 ap_get_basic_auth_pw() API 函式,可能造成略過身份驗證。如果 httpd 所使用的其中一個模組錯誤使用了 API,遠端攻擊者可能會利用此缺陷略過必要的驗證。(CVE-2017-3167) * 在 httpd 的 mod_ssl module 模組中發現 NULL 指標解除參照缺陷。如果 httpd 所用的另一個模組在處理 HTTPS 要求期間呼叫了特定 API 函式,遠端攻擊者可利用此缺陷造成 httpd 子處理程序損毀。(CVE-2017-3169) * 在 httpd 的 mod_mime 模組中發現緩衝區過度讀取缺陷。有權修改 httpd MIME 組態的使用者可利用此缺陷造成 httpd 子程序損毀。(CVE-2017-7679)

解決方案

更新受影響的 httpd 套件。

另請參閱

https://oss.oracle.com/pipermail/el-errata/2017-August/007128.html

Plugin 詳細資訊

嚴重性: Critical

ID: 102514

檔案名稱: oraclelinux_ELSA-2017-2478.nasl

版本: 1.9

類型: local

代理程式: unix

已發布: 2017/8/16

已更新: 2021/1/14

相依性: ssh_get_info.nasl

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:oracle:linux:httpd, p-cpe:/a:oracle:linux:httpd-devel, p-cpe:/a:oracle:linux:httpd-manual, p-cpe:/a:oracle:linux:httpd-tools, p-cpe:/a:oracle:linux:mod_ssl, cpe:/o:oracle:linux:6

必要的 KB 項目: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2017/8/15

弱點發布日期: 2017/6/20

參考資訊

CVE: CVE-2017-3167, CVE-2017-3169, CVE-2017-7679, CVE-2017-9788

RHSA: 2017:2478