Debian DSA-3913-1:apache2 - 安全性更新

critical Nessus Plugin ID 101793

Synopsis

遠端 Debian 主機缺少安全性更新。

描述

Robert Swiecki 報告 mod_auth_digest 未能正確初始化或重設「Digest」類型之 [Proxy-]Authorization 標頭中位於連續的 key=value 指派之間的數值預留位置,會導致洩漏資訊或拒絕服務。

解決方案

升級 apache2 套件。針對舊的穩定發行版本 (jessie),此問題已在 2.4.10-10+deb8u10 版本中修正。針對穩定的發行版本 (stretch),此問題已在 2.4.25-3+deb9u2 版本中修正。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=868467

https://packages.debian.org/source/jessie/apache2

https://packages.debian.org/source/stretch/apache2

https://www.debian.org/security/2017/dsa-3913

Plugin 詳細資訊

嚴重性: Critical

ID: 101793

檔案名稱: debian_DSA-3913.nasl

版本: 3.12

類型: local

代理程式: unix

已發布: 2017/7/19

已更新: 2021/1/4

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:apache2, cpe:/o:debian:debian_linux:8.0, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2017/7/18

參考資訊

CVE: CVE-2017-9788

DSA: 3913