Apache 2.4.x < 2.4.27 多個弱點

critical Nessus Plugin ID 101788

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

根據其標題,遠端主機上執行的 Apache 版本是比 2.4.27 舊的 2.4.x 版。因此,該應用程式受到以下弱點影響:

- httpd 中存在拒絕服務弱點,這是 mod_auth_digest 未能在連續 key=value 指派之前或之間,初始化或重設 [Proxy-]Authorization 標頭 (「Digest」類型) 中的數值預留位置所致。未經驗證的遠端攻擊者可利用此弱點,透過提供無「=」指派的初始金鑰,洩漏敏感資訊或造成拒絕服務情形。(CVE-2017-9788)

- httpd 中存在釋放後讀取錯誤,此錯誤會在關閉大量連線時觸發。未經驗證的遠端攻擊者可利用此錯誤造成不明影響。(CVE-2017-9789)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.27 或更新版本。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.4.27

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: Critical

ID: 101788

檔案名稱: apache_2_4_27.nasl

版本: 1.15

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2017/7/18

已更新: 2022/4/11

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2017-9788

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2017/7/11

弱點發布日期: 2017/7/11

參考資訊

CVE: CVE-2017-9788, CVE-2017-9789

BID: 99568, 99569