Apache 2.2.x < 2.2.34 多個漏洞

critical Nessus Plugin ID 101787
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器受到多個弱點的影響。

描述

根據其標題,遠端主機上執行的 Apache 版本是比 2.2.34 舊的 2.2.x 版。因此,會受到以下弱點影響:- httpd 中有一個驗證繞過弱點存在,這是因為驗證階段外使用 ap_get_basic_auth_pw() 函式的第三方模組所致。未經驗證的遠端攻擊者可惡意利用此弱點繞過驗證需求。(CVE-2017-3167) - httpd 中有一個拒絕服務弱點存在,這是因為 NULL 指標解除參照缺陷所致,該缺陷會在對 HTTPS 連接埠提出 HTTP 要求時,第三方模組對 mod_ssl ap_hook_process_connection() 函式發出呼叫時遭到觸發。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2017-3169) - httpd 中存在一個拒絕服務弱點,這是因為 ap_find_token() 函式中的超出邊界讀取錯誤所致,該錯誤會在處理特製的要求標頭順序時遭到觸發。未經驗證的遠端攻擊者可加以惡意利用,以導致服務損毀,或迫使 ap_find_token() 傳回不正確的值。(CVE-2017-7668) - httpd 中存在一個拒絕服務弱點,這是因為 mod_mime 中的超出邊界讀取錯誤所致,該錯誤會在處理特製的內容類型回應標頭時遭到觸發。未經驗證的遠端攻擊者可惡意利用此弱點,洩漏敏感資訊或造成拒絕服務情形。(CVE-2017-7679) - httpd 中有一個拒絕服務弱點存在,這是因為 mod_auth_digest 未能在連續 key=value 指派之前或之間,初始化或重設 [Proxy-]Authorization 標頭 (「Digest」類型) 中的數值預留位置所致。未經驗證的遠端攻擊者可加以惡意利用,透過提供無「=」指派的初始金鑰來洩漏敏感資訊,或造成拒絕服務情形。(CVE-2017-9788) 請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.2.34 或更新版本。

另請參閱

https://archive.apache.org/dist/httpd/CHANGES_2.2.34

https://httpd.apache.org/security/vulnerabilities_22.html

Plugin 詳細資訊

嚴重性: Critical

ID: 101787

檔案名稱: apache_2_2_34.nasl

版本: 1.12

類型: remote

系列: Web Servers

已發布: 2017/7/18

已更新: 2018/9/17

相依性: apache_http_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2017-3167

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2017/7/11

弱點發布日期: 2017/7/11

參考資訊

CVE: CVE-2017-3167, CVE-2017-3169, CVE-2017-7668, CVE-2017-7679, CVE-2017-9788

BID: 99134, 99135, 99137, 99170, 99569