PHP 5.6.x < 5.6.31 多個弱點

critical Nessus Plugin ID 101525
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

根據其標題,遠端網頁伺服器上安裝的 PHP 版本為 5.6.31 之前的 5.6.x 版。因此,會受到以下弱點影響:- 在 PCRE 程式庫中,檔案 pcre_jit_compile.c 的 compile_bracket_matchingpath() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,透過特製的規則運算式,損毀連結至程式庫的處理程序,進而導致拒絕服務情形。(CVE-2017-6004) - 在 GD 圖行程式庫 (LibGD) 中處理特製的 GIF 檔案時,檔案 gd_gif_in.c 的 gdImageCreateFromGifCtx() 函式的存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,洩漏敏感的記憶體內容或損毀連結至程式庫的處理程序。(CVE-2017-7890) - 在 Oniguruma 中,檔案 regexec.c 的 match_at() 函式中存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,洩漏敏感的記憶體內容或損毀連結至程式庫的處理程序。(CVE-2017-9224) - 在 Oniguruma 中,在規則運算式編譯過程中,next_state_val() 函式存在一個超出邊界寫入錯誤。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。(CVE-2017-9226) - 在 Oniguruma 中,檔案 utf8.c 的 mbc_enc_len() 函式存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,洩漏記憶體內容或損毀連結至程式庫的處理程序。(CVE-2017-9227) - 在 Oniguruma 中,在規則運算式編譯過程中,bitset_set_range() 函式存在一個超出邊界寫入錯誤。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。(CVE-2017-9228) - 在 Oniguruma 中,在規則運算式編譯過程中,檔案 regexec.c 的 left_adjust_char_head() 函式存在一個無效指標解除參照缺陷。未經驗證的遠端攻擊者可加以惡意利用,損毀連結至程式庫的處理程序,進而導致拒絕服務情形。(CVE-2017-9229) - 在處理過大的 POST 要求時,PHP 中存在一個拒絕服務情形。未經驗證的遠端攻擊者可惡意利用此情形,藉此耗盡可用 CPU 資源。(CVE-2017-11142) - 在 PHP 中,剖析空布林值標記時,檔案 ext/wddx/wddx.c 的 php_wddx_push_element() 函式中存在一個延伸無效釋放錯誤。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2017-11143) - 在 OpenSSL 中,檔案 crypto/evp/p_seal.c 的 EVP_SealInit() 函式存在一個缺陷,這是因為傳回未記錄的值「-1」所致。未經驗證的遠端攻擊者可加以惡意利用,而造成不明影響。(CVE-2017-11144) - 在 PHP 中,檔案 ext/date/lib/parse_date.c 的 php_parse_date() 函式存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,進而造成洩漏記憶體內容或是拒絕服務情形。(CVE-2017-11145) - 在 PHP 中,檔案 ext/standard/var_unserializer.re 的 finish_nested_data() 函式存在一個超出邊界讀取錯誤。未經驗證的遠端攻擊者可加以惡意利用,進而造成洩漏記憶體內容或是拒絕服務情形。- 在 PHP 中,INI 剖析 API 存在一個差一溢位情形,尤其是在檔案 Zend/zend_ini_parser.y 的 zend_ini_do_op() 函式中,這是因為不當驗證使用者提供的輸入所致。未經驗證的遠端攻擊者可加以惡意利用,藉此引發拒絕服務情形或執行任意程式碼。- 解除序列化未受信任資料時,finish_nested_data 中的堆積緩衝區過度讀取缺陷會導致對 PHP 的完整性造成不明影響。(CVE-2017-12933) - 在 Zend/zend_ini_parser.c 中,zend_ini_do_op() 函式內的堆疊型緩衝區溢位會導致拒絕服務,或可能允許執行程式碼。(CVE-2017-11628) 請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級為 PHP 5.6.31 或更新版本。

另請參閱

http://www.php.net/ChangeLog-5.php#5.6.31

Plugin 詳細資訊

嚴重性: Critical

ID: 101525

檔案名稱: php_5_6_31.nasl

版本: 1.14

類型: remote

系列: CGI abuses

已發布: 2017/7/13

已更新: 2019/3/4

相依性: php_version.nasl

風險資訊

CVSS 評分資料來源: CVE-2017-9224

VPR

風險因素: Medium

分數: 5.9

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP

可輕鬆利用: No exploit is required

修補程式發佈日期: 2017/7/6

弱點發布日期: 2016/12/23

參考資訊

CVE: CVE-2017-6004, CVE-2017-7890, CVE-2017-9224, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229, CVE-2017-11142, CVE-2017-11143, CVE-2017-11144, CVE-2017-11145, CVE-2017-11628, CVE-2017-12933

BID: 96295, 99489, 99490, 99492, 99501, 99550, 99553, 99601, 99605, 100320, 100538, 101244