Tenable SecurityCenter PHP < 5.6.25 Multiple Vulnerabilities (TNS-2016-09)

critical Nessus Plugin ID 101047
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端主機上的 Tenable SecurityCenter 應用程式含有受到多個弱點影響的 PHP 程式庫。

描述

遠端主機上安裝的 Tenable SecurityCenter 應用程式缺少安全性修補程式。因此受到隨附 PHP 版本中的多個弱點影響:- 在 var_unserializer.c 的 object_common2() 函式中,存在一個在還原序列化期間處理物件時發生的不明缺陷。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。(CVE-2016-7124) - 在 session.c 中,存在一個在處理工作階段名稱時發生的不明缺陷。未經驗證的遠端攻擊者可惡意利用此缺陷,將任意資料插入工作階段。(CVE-2016-7125) - 在 gd_topal.c 的 select_colors() 函式中,存在一個在處理色彩數時遭到觸發的整數截斷缺陷。未經驗證的遠端攻擊者可惡意利用此缺陷,造成堆積型緩衝區溢位,進而導致任意程式碼執行。(CVE-2016-7126) - 在 gd.c 的 imagegammacorrect() 函式中,存在一個在處理負色差補正值時發生的索引缺陷。未經驗證的遠端攻擊者可惡意利用此缺陷,將 NULL 寫入至任意記憶體位置,進而導致拒絕服務情形,或是執行任意程式碼。(CVE-2016-7127) - 在 exif.c 的 exif_process_IFD_in_TIFF() 函式中,存在一個在處理 TIFF 影像內容時發生的缺陷。未經驗證的遠端攻擊者可加以惡意利用,洩露記憶體內容。(CVE-2016-7128) - 在 wddx.c 的 php_wddx_process_data() 函式中,存在一個在還原序列化無效 dateTime 值時發生的缺陷。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2016-7129) - 在 wddx.c 的 php_wddx_pop_element() 函式中,存在一個在處理 Base64 二進位值期間遭到觸發的 NULL 指標解除參照缺陷。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2016-7130) - 在 wddx.c 的 php_wddx_deserialize_ex() 函式中,存在一個在處理無效 XML 內容期間發生的 NULL 指標解除參照缺陷。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。(CVE-2016-7131) - 在 wddx.c 的 php_wddx_pop_element() 函式中,存在一個不明的 NULL 指標解除參照缺陷。未經驗證的遠端攻擊者可加以惡意利用,進而引發拒絕服務情形。CVE-2016-7132) - 在 snmp.c 的 php_snmp_parse_oid() 函式中,有整數溢位情形存在。未經驗證的遠端攻擊者可利用此問題造成堆積型緩衝區溢位,進而執行任意程式碼。- 在 ereg.c 的 sql_regcase() 函式中存在一個溢位情形,這是因為不當處理過長字串所導致。未經驗證的遠端攻擊者可惡意利用此弱點損毀記憶體,進而導致任意程式碼執行。- 在 base64.c 的 php_base64_encode() 函式中,存在一個處理過長字串時發生的整數溢位情形。未經驗證的遠端攻擊者可利用此弱點執行任意程式碼。- 在 quot_print.c 的 hp_quot_print_encode() 函式中,存在一個處理過長字串時發生的整數溢位情形。未經驗證的遠端攻擊者可惡意利用此情形,造成堆積型緩衝區溢位情形,進而導致任意程式碼執行。- 在 var.c 的 unserialize() 函式中存在一個釋放後使用錯誤。未經驗證的遠端攻擊者可加以惡意利用,解除參照已釋放的記憶體,進而導致執行任意程式碼。- 在 ftp_fopen_wrapper.c 的 php_ftp_fopen_connect() 函式中,存在一個即使已經要求安全方法,還是會允許攔截式攻擊者以無訊息的方式降級至一般 FTP 的缺陷。- 在 url.c 的 php_url_encode() 函式中,存在一個處理過長字串時發生的整數溢位情形。未經驗證的遠端攻擊者可惡意利用此弱點損毀記憶體,進而導致任意程式碼執行。- 在 uuencode.c 的 php_uuencode() 函式中存在一個整數溢位情形。未經驗證的遠端攻擊者可惡意利用此弱點損毀記憶體,進而導致任意程式碼執行。- 在 bz2.c 的 bzdecompress() 函式中,存在一個整數溢位情形。未經驗證的遠端攻擊者可惡意利用此弱點損毀記憶體,進而導致任意程式碼執行。- 在 interface.c 的 curl_escape() 函式中,存在一個處理過長逸出字串時發生的整數溢位情形。未經驗證的遠端攻擊者可惡意利用此弱點損毀記憶體,進而導致任意程式碼執行。請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 SecurityCenter 5.4.1 版或更新版本。或者,也可聯絡供應商取得修補程式。

另請參閱

https://www.tenable.com/security/tns-2016-19

http://php.net/ChangeLog-5.php#5.6.25

Plugin 詳細資訊

嚴重性: Critical

ID: 101047

檔案名稱: securitycenter_php_5_6_25.nasl

版本: 1.8

類型: combined

代理程式: unix

系列: Misc.

已發布: 2017/6/26

已更新: 2020/10/9

相依性: securitycenter_installed.nbin, securitycenter_detect.nbin

風險資訊

CVSS 評分資料來源: CVE-2016-7124

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:tenable:securitycenter

必要的 KB 項目: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2016/11/28

弱點發布日期: 2016/8/10

參考資訊

CVE: CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132

BID: 92552, 92564, 92755, 92756, 92757, 92758, 92764, 92767, 92768