ISC BIND 9.x.x < 9.9.10-P1 / 9.10.x < 9.10.5-P1 / 9.11.x < 9.11.1-P1 多個弱點

high Nessus Plugin ID 100996
新推出!Plugin 嚴重性目前使用 CVSS v3

計算 Plugin 嚴重性已更新為預設使用 CVSS v3 沒有 CVSS v3 評分的 Plugin 會回歸到以 CVSS v2 計算嚴重性。您可在設定下拉式選單中切換顯示嚴重性的喜好設定

Synopsis

遠端名稱伺服器受到多個弱點影響。

描述

根據其自我報告的版本號碼,在遠端名稱伺服器上執行的 ISC BIND 執行個體為 9.9.10-P1 之前的 9.x.x 版、9.10.5-P1 之前的 9.10.x 版或是 9.11.1-P1 之前的 9.11.x 版。因此,會受到多個弱點影響:- 處理回應原則區域 (RPZ) 規則類型時,存在一個拒絕服務弱點。未經驗證的遠端攻擊者可惡意利用此弱點,透過特製的查詢造成無限迴圈情形,進而降低伺服器的功能。(CVE-2017-3140) - 因為使用不具引號的服務路徑,Windows BIND 安裝程式存在一個權限提升弱點。如果主機檔案系統權限允許,本機攻擊者可惡意利用此弱點取得提升權限。請注意,非 Windows 組建和安裝不受影響。(CVE-2017-3141)

解決方案

升級至 ISC BIND 9.9.10-P1 / 9.9.10-S2 / 9.10.5-P1 / 9.10.5-S2 / 9.11.1-P1 版或更新版本。請注意,BIND 9 的 9.9.10-S2 和 9.10.5-S2 版僅提供符合資格的 ISC Support 客戶專用。

另請參閱

https://kb.isc.org/docs/aa-01495

https://kb.isc.org/docs/aa-01496

Plugin 詳細資訊

嚴重性: High

ID: 100996

檔案名稱: bind9_9111_p1.nasl

版本: 1.11

類型: remote

系列: DNS

已發布: 2017/6/22

已更新: 2019/11/13

相依性: bind_version.nasl

組態: 啟用 Paranoid 模式

風險資訊

CVSS 評分資料來源: CVE-2017-3141

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.2

時間分數: 5.6

媒介: AV:L/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 7

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:isc:bind

必要的 KB 項目: bind/version, Settings/ParanoidReport

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2017/6/14

弱點發布日期: 2017/6/4

參考資訊

CVE: CVE-2017-3140, CVE-2017-3141

BID: 99088, 99089

EDB-ID: 42121