Zabbix 2.0.x < 2.0.21 / 2.2.x < 2.2.18 / 3.0.x < 3.0.9 / 3.2.x < 3.2.5 多個弱點

high Nessus Plugin ID 100615

Synopsis

遠端主機上執行的 Web 應用程式受到多個弱點影響。

描述

根據其自我報告的版本號碼,在遠端主機上執行的 Zabbix 執行個體為比 2.0.21 舊的 2.0.x 版、比 2.2.18 舊的 2.2.x 版、比 3.0.9 舊的 3.0.x 版,或比 3.2.5 舊的 3.2.x 版。因此,會受到多個弱點影響:- trapper 命令功能中存在一個遠端程式碼執行弱點,這是因為不當處理 trapper 封包所致。未經過驗證的遠端攻擊者可惡意利用此弱點,透過特製的 trapper 封包集來插入任意命令並執行任意程式碼。(CVE-2017-2824 / TALOS-2017-0325) - trapper 命令功能中存在一個安全性繞過弱點,這是因為不當處理 trapper 封包所致。攔截式 (MitM) 攻擊者可惡意利用此弱點,透過特製的 trapper 封包繞過資料庫安全性檢查,並將任意資料寫入資料庫。(CVE-2017-2825 / TALOS-2017-0326) 請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Zabbix 2.0.21 / 2.2.18 / 3.0.9 / 3.2.5 版或更新版本。或者,您可以依據 TALOS-2017-0325 公告刪除 Zabbix 伺服器中的三個預設指令碼項目,以減輕 CVE-2017-2824 弱點的嚴重性。

另請參閱

https://blog.talosintelligence.com/2017/04/zabbix-multiple-vulns.html

https://www.talosintelligence.com/reports/TALOS-2017-0325/

https://www.talosintelligence.com/reports/TALOS-2017-0326/

https://support.zabbix.com/browse/ZBX-12075

https://support.zabbix.com/browse/ZBX-12076

Plugin 詳細資訊

嚴重性: High

ID: 100615

檔案名稱: zabbix_frontend_3_2_5.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2017/6/5

已更新: 2022/4/11

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2017-2825

CVSS v3

風險因素: High

基本分數: 7

時間分數: 6.1

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:zabbix:zabbix

必要的 KB 項目: installed_sw/zabbix, Settings/ParanoidReport

可輕鬆利用: No exploit is required

修補程式發佈日期: 2017/4/27

弱點發布日期: 2017/4/27

參考資訊

CVE: CVE-2017-2824, CVE-2017-2825

BID: 98083, 98094