Apache Log4j 2.x < 2.16.0 RCE (MacOS)

critical Nessus Plugin ID 156165

Synopsis

遠端主機上安裝的套件受到遠端程式碼執行弱點影響。

描述

遠端主機上的 Apache Log4j 版本為 2.16.0 之前的 2.x 版。因此,會受到遠端程式碼執行弱點影響。據發現,在某些非預設組態中,對 Apache Log4j CVE-2021-44228 中位址 2.15.0 的修正不完整。當記錄組態使用具有內容查閱 (例如,$${ctx: loginId}) 的非預設模式配置時,控制執行緒內容對應 (MDC) 輸入資料的攻擊者可使用 JNDI 查閱模式建構惡意輸入資料,進而在某些環境中造成資訊洩漏和遠端程式碼執行,以及在所有環境中造成本機程式碼執行;已在 macOS 上示範遠端程式碼執行,但尚未在其他測試環境中進行示範。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache Log4j 2.16.0 或更高版本,或者採用廠商的緩解措施。

強烈建議升級至 Apache Log4j 最新版本,因為中繼版本/修補程式中存在已知的高嚴重性弱點,而且供應商會經常在發現與 Log4j 相關的新研究和新知識時更新其公告。請參閱 https://logging.apache.org/log4j/2.x/security.html 了解最新版本。

另請參閱

https://logging.apache.org/log4j/2.x/security.html

Plugin 詳細資訊

嚴重性: Critical

ID: 156165

檔案名稱: apache_log4j_2_16_0_mac.nasl

版本: 1.8

類型: local

代理程式: macosx

已發布: 2021/12/17

已更新: 2021/12/31

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Critical

分數: 9.2

CVSS v2

風險因素: Medium

基本分數: 5.1

媒介: AV:N/AC:H/Au:N/C:P/I:P/A:P

CVSS 評分資料來源: CVE-2021-45046

CVSS v3

風險因素: Critical

基本分數: 9

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

弱點資訊

CPE: cpe:/a:apache:log4j

必要的 KB 項目: installed_sw/Apache Log4j, Host/MacOSX/Version

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/14

弱點發布日期: 2021/12/14

參考資訊

CVE: CVE-2021-45046

IAVA: 2021-A-0573, 2021-A-0596, 2021-A-0598, 0001-A-0650