Facebook Google Plus Twitter LinkedIn YouTube RSS 功能表 搜尋 Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Solr < 5.0 Multiple XXE

Medium

Synopsis

The remote web server contains a Java application that is affected by multiple XXE (Xml eXternal Entity) attack vectors.

Description

Versions of Apache Solr prior to 5.0 are affected by multiple vulnerabilities :

- A XXE injection flaw exists in 'UpdateRequestHandler' that is triggered during the parsing of XML data.The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source.By sending specially crafted XML data, a remote attacker can gain access to arbitrary files.(CVE-2012-6612, CVE-2013-6407) - A XXE injection flaw in 'DocumentAnalysisRequestHandler' exists that is triggered during the parsing of XML data.The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source.By sending specially crafted XML data, a remote attacker can gain access to arbitrary files.(CVE-2013-6408)

解決方案

Upgrade to Solr 5.0 or later.